When I connect to play.geforcenow.com on my iPhone or iPad, why do I see an unsupported device message even though my iOS/iPadOS version is up-to-date?

Updated 09/29/2021 01:16 PM

When I connect to play.geforcenow.com on my iPhone or iPad, why do I see an unsupported device message even though my iOS/iPadOS version is up-to-date?


Recently we raised our minimum requirement to iOS/PadOS Safari from 14+ to 14.0.3+. There is currently a bug with iOS/iPadOS Safari which caches the iOS version for any URL you have visited.

As a result iOS/iPadOS Safari may report older iOS versions from cache to GeForce NOW app. This will result in an error message when you visit play.geforcenow.com and you will get an error message that you are running on an unsupported device.

You can work around this issue by clearing Safari’s cache.

Is this answer helpful?

Live Chat

Chat online with one of our support agents

CHAT NOW

ASK US A QUESTION

Contact Support for assistance

Ask a Question